Home > Projects > gen_announce v0.3.1 build 71 released

gen_announce v0.3.1 build 71 released

December 20th, 2005 Mark Leave a comment Go to comments

A couple of bugfixes thanks to input from Stu and Darren

Fixes:

  • MSN Messenger output didn’t work when an ID3 wasn’t present
  • Part of MySQL command wasn’t escaped properly when ID3 wasn’t present

gen_announce combo screenshot

Download here: gen_announce_v0_3_1_71.exe

Categories: Projects Tags:
  1. Andrew
    June 9th, 2006 at 00:08 | #1

    Just a note the plugin doesnt work on MSN 8.0 BETA… so that would be great if you fixed it…

  2. June 9th, 2006 at 06:50 | #2

    Hi Andrew,

    I’m using 8.0 BETA also [8.0 (Build 8.0.0689.00_Branches) – and it’s working fine… it worked on previous BETA versions but there was a bug in Messenger which caused the song name to be displayed improperly

    So unfortunately I can’t help you!

    Just make sure the MSN Messenger module is active in the plugin properties

  3. Tofu
    June 26th, 2006 at 16:28 | #3

    iv got 2 databases wich database gen_an will use? cause i cant set it.
    and a database connection test button would be cool!

  4. June 26th, 2006 at 17:39 | #4

    Test button is a good idea, I’ll add one soon

    Regarding which database to use.. just modify your SQL command, e.g.

    insert into `dbname`.`tablename` (`songplayed`) values (%s)

  5. August 3rd, 2006 at 11:43 | #5

    Hi there,

    Thanks for the nice plugin!
    I might create a script to turn this into a small plugin for wordpress :) (just a idea for now!)

    Unfortunatly im running into some issues:

    1. Winamp module doesn’t work for me. Im using live messenger. The module is activated in Messenger and WMP and some other plugins in winamp do work. Yours so far doesnt.

    2. (more important) I cant get mysql to work.
    using Fedora core 3 and MySQL 4.1.12. SSH enable and all logins work. Currently im using root for both SSH and MySQL just to make sure i have enought privileges. This will be changed later when i get it to work.

    I’ve created this table in the wordpress datase:
    wp_winamp

    artist varchar(255)
    track varchar(255)
    thetime int(15)

    And am using this query:
    INSERT INTO `wordpress`.`wp_winamp` (`artist`, `track`, `thetime`) VALUES (`%artist%`, `%title%`, `time()`)

    Using these settings (these work on phpmyadmin):
    Localhost (also tried 127.0.0.1)
    root
    (password)

    SSH (this works in putty):
    192.168.2.2
    root
    (password)

    Any clue? Thanks alot!

  6. August 3rd, 2006 at 12:29 | #6

    After some digging on mysql.com it appears time() is not valid.

    Also i dont need the SSH tunnel for some reason. Did you remove the security thingy you mention in one of your posts?

  7. August 10th, 2006 at 13:01 | #7

    Hi,

    Sorry for late reply, been out of the country on holiday!

    The SSH tunnel is only required if the MySQL server you are trying to access only allows connections from localhost and you’re not on the same server, i.e. most hosted MySQL databases

    As for why the Winamp module isn’t working – I’m stumped.. every version I’ve tested it with has worked alright.. what version is it?

    Also, what type of file are you playing? Try adding a few different MP3s to your playlist and go through them – see if any show up

    Thanks

  8. August 11th, 2006 at 12:39 | #8

    Hi mark,

    yes it was a query error. I tried to use a php function in the query (didnt think that one thru)

    I notice that internet radios usually are not or minimal supported even with the %s variable. A empty thing gets saved. Mp3′s with no tag do get recognized and saved. So i guess its something with the radios being different.

    http://www.sothq.net/projects/winamp-plugin/winamp-demo/ Thats what i came up with so far. I didnt really had much time lately.

    Also i’m wondering why your plugin tries to save the title every 10 seconds for a radio stream. I think it has to do with the buffering of the stream which is also 10 seconds. Or maybe it has something to do with the title missing. Im not sure. Maybe you can create some sort of workaround or timer thingy to make it work better with radios :)

    Anyway. regarding my wordpress plugin. Im trying to expand the page in the url above and release it somewhere next month (or whenever its finished) I need to work on the layout and think of some way to get more stats out of the data saved. :)

  1. No trackbacks yet.